Request to remove AWS instance name


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
ec2-18-237-108-176.us-west-2.compute.amazonaws.com

I ran this command:
sudo certbot --apache --domain ec2-18-237-108-176.us-west-2.compute.amazonaws.com --email dev@hellotractor.com --agree-tos --no-eff-email --non-interactive --redirect

It produced this output:
An unexpected error occurred:
Error creating new authz :: Policy forbids issuing for name

My web server is (include version):
Server version: Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 16.04.4 LTS

My hosting provider, if applicable, is:
AWS

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


#2

@cpu I read you have super powers.


#3

Hi @rbrisita,

amazonaws.com is in the blacklist so you won’t be able to issue a certificate for your hostname, use your own domain instead.

For the reason why it is blacklisted, take a look to this post:

Cheers,
sahsanu


#4

My justice league of community support superheroes are the true source of my power and @sahsanu is a perfect example :slight_smile:

His response is correct for this case.


#5

Thanks for the explanation.

Since this was a development server I would have guessed ‘–test-cert’ would have worked but I got the same response. This gives me the idea for a ‘–self-signed’ option where it would configure Apache or Nginx appropriately.

Thoughts?


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.