Renewing certificates failed with urllib2.URLError

My domain is:

I ran this command:
/root/certbot-auto renew --no-bootstrap --disable-hook-validation --renew-hook “service httpd reload”
It produced this output:
Creating virtual environment…
Installing Python packages…
Traceback (most recent call last):
File “/tmp/tmp.GivcbDQtYj/”, line 177, in
File “/tmp/tmp.GivcbDQtYj/”, line 158, in main
for path, digest in PACKAGES]
File “/tmp/tmp.GivcbDQtYj/”, line 117, in hashed_download
response = opener(using_https=parsed_url.scheme == ‘https’).open(url)
File “/usr/local/lib/python2.7/”, line 431, in open
response = self._open(req, data)
File “/usr/local/lib/python2.7/”, line 449, in _open
‘_open’, req)
File “/usr/local/lib/python2.7/”, line 409, in _call_chain
result = func(*args)
File “/usr/local/lib/python2.7/”, line 1240, in https_open
File “/usr/local/lib/python2.7/”, line 1197, in do_open
raise URLError(err)
urllib2.URLError: <urlopen error EOF occurred in violation of protocol (_ssl.c:581)>

My web server is (include version):
Server version: Apache/2.2.27 (Unix)

1 Like

Which version of certbot-auto?

1 Like

When I run certbot-auto --version, I got the same urllib2 error, my python version is 2.7.

1 Like

I would try reloading it:
[maybe in a different directory]
And also check the o/s - make sure it is also up-to-date.

1 Like

This might help further troubleshoot the issue:

curl -X GET -I
echo "${PIP_INDEX_URL:-url not set}"
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.