Unable to renew certificate using certbot-auto

#1

My domain is:
www.renewate.com

I ran this command:
./certbot-auto renew

It produced this output:

Creating virtual environment…
Installing Python packages…
/opt/eff.org/certbot/venv/bin/python: No module named pip.main; ‘pip’ is a package and cannot be directly executed
Traceback (most recent call last):
File “/tmp/tmp.AFlFmwRQLU/pipstrap.py”, line 177, in
sys.exit(main())
File “/tmp/tmp.AFlFmwRQLU/pipstrap.py”, line 149, in main
pip_version = StrictVersion(check_output([python, ‘-m’, ‘pip’, ‘–version’])
File “/usr/lib/python2.7/subprocess.py”, line 544, in check_output
raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command ‘[’/opt/eff.org/certbot/venv/bin/python’, ‘-m’, ‘pip’, ‘–version’]’ returned non-zero exit status 1

My web server is (include version):
Apache/2.2.22 (Debian)

The operating system my web server runs on is (include version):
Debian GNU/Linux 7.11 (wheezy)

My hosting provider, if applicable, is:
Google cloud compute engine

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No

#2

Recent versions of certbot-auto are no longer compatible with the old version of pip shipped by Debian Wheezy.

You have options, particularly using an older version of certbot-auto, or patching it.

See:

1 Like
#3

Hi,
The solution given in other issue worked.
Thank you :grinning: