Certbot-auto renew failed

Please help me as I am trying to renew our company certificates

My domain is: https://staging-timesheet.dius.com.au/

I ran this command: ./certbot-auto renew

It produced this output:

Creating virtual environment…
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/virtualenv.py”, line 2283, in
File “/usr/lib/python2.7/dist-packages/virtualenv.py”, line 938, in main
File “/usr/lib/python2.7/dist-packages/virtualenv.py”, line 1052, in create_environment
search_dirs=search_dirs, never_download=never_download)
File “/usr/lib/python2.7/dist-packages/virtualenv.py”, line 601, in install_distribute
search_dirs=search_dirs, never_download=never_download)
File “/usr/lib/python2.7/dist-packages/virtualenv.py”, line 567, in _install_req
File “/usr/lib/python2.7/dist-packages/virtualenv.py”, line 1016, in call_subprocess
% (cmd_desc, proc.returncode))
OSError: Command /opt/eff.org/certbot/venv/bin/python2.7 -c "#!python
“”"Bootstra… main(sys.argv[1:])
" --always-copy -U distribute failed with error code 1
Traceback (most recent call last):
File “”, line 27, in
File “”, line 19, in create_venv
File “/usr/lib/python2.7/subprocess.py”, line 511, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘virtualenv’, ‘–no-site-packages’, ‘–python’, ‘/usr/bin/python2.7’, ‘/opt/eff.org/certbot/venv’]’ returned non-zero exit status 1


VERSION=“12.04.5 LTS, Precise Pangolin”
PRETTY_NAME=“Ubuntu precise (12.04.5 LTS)”

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot --version & certbot-auto --version ; do not work and produce the same error after ‘creating virtual environment’

Hi @duketis,

Unfortunately, according to http://releases.ubuntu.com/12.04/,

Ubuntu 12.04 LTS reached its regular End of Life on April 28, 2017. No more package updates, including security updates, will be accepted to the 12.04 primary archive.

I suspect that your operating system has some out-of-date packages that can’t be upgraded anymore due to the discontinuation of support from Canonical. We are not attempting to make certbot-auto work on operating systems that are no longer supported by their distributors due to difficulties with getting operating system dependencies to work properly in unsupported environments.

I would suggest upgrading this system to a new Ubuntu release as soon as possible (particularly since it can no longer receive any security updates, unless you’ve purchased the Extended Security Support service). In the meantime, you might want to try another Let’s Encrypt client with fewer dependencies.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.