Renewal problem


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is :rjilbutler.id.au

I ran this command: certbot certonly --debug-challenges -v --dry-run --standalone --agree-tos --email russell@rjilbutler.id.au -d www.rjilbutler.id.au,rjilbutler.id.au,mail.rjilbutler.id.au,smtp.rjilbutler.id.au

It produced this output: Domain: rjilbutler.id.au
Type: connection
Detail: Fetching
http://rjilbutler.id.au/.well-known/acme-challenge/ukC1q0zAWUilvU0v3T2sWfA63Yn1xGRq_0Se9WPIR4A:
Timeout during connect (likely firewall problem)

My web server is (include version): lighttpd (stopped for test)

The operating system my web server runs on is (include version):Ubuntu 16.04

My hosting provider, if applicable, is:self hosted

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no
https://pastebin.com/UWZdxfVy


#2

Are you sure you have port 80 properly forwarded in your modem/router?

The way it currently behaves indicates that it is either not forwarded or filtered. This is distinct to simply having your web server stopped.


#3

Thanks for the repsonse.
Yes port forwarding is OK, The renewals have worked with the basis of that script for the last year.


#4

Edit: you changed something as I was typing, as it no longer times out for me.


#5

OOPs ,I thought I had checked that, just did so again and found it was to a different address.
I thought I had made some elementary error.


#6

Repeat dry-run was successful.

These birthdays are a health hazard.

Thanks and Happy New Year to all


closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.