Renewal problem

My domain is: or

I ran this command:
certbot renew

It produced this output:
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
http-01 challenge for
Cleaning up challenges
Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: Missing command line flag or config entry for this setting:
Input the webroot for Skipping.

My web server is (include version):
Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 18.04.3 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.31.0

Here is the content of my .conf file
<VirtualHost *:80>
DocumentRoot /var/www/html/wordpress

RewriteEngine on

RewriteRule ^.well-known - [L]

Redirect permanent /

<VirtualHost *:443>
DocumentRoot /var/www/html/wordpress

<Directory “/var/www/html/wordpress”>
Options -Indexes
Order allow,deny
Allow from all
AllowOverride FileInfo
Require all granted

Include /etc/letsencrypt/options-ssl-apache.conf

SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/

Header always set Content-Security-Policy "default-src https: data: ‘unsafe-inline’ 'unsafe-eval$
Header always set Feature-Policy "geolocation ‘none’; midi ‘none’; camera ‘none’; usb ‘none’; ma$
Header always set Referrer-Policy “same-origin”

ErrorLog /var/log/apache2/wp.error.log
CustomLog /var/log/apache2/wp.access.log combined

I tried to find an answer in the forum without succes…
Any help would be appreciated :slight_smile:

1 Like

Due to a bug fixed in a later version of Certbot, /etc/letsencrypt/renewal/ is missing your web root path setting.

Manually specifying it with “certbot renew -w /var/www/html/wordpress” – or whatever the path is – may work.

If not, try running the command you used to create the certificate originally, e.g. “certbot certonly --webroot -d mikmer...”.


Thanks a lot mnordhoff : it works with -w option !


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.