Renewal failed: Missing command line flag or config

My domain is:

I ran this command: sudo certbot renew

It produced this output:

http-01 challenge for
http-01 challenge for
Cleaning up challenges
Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: Missing command line flag or config entry for this setting:
Input the webroot for Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/ (failure)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/ (failure)

My web server is: Ubuntu

The operating system my web server runs on is: Apache 2

My hosting provider, if applicable, is: digital ocean

I can login to a root shell on my machine:: Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is 0.31.0

Apache ctl gives:

VirtualHost configuration:
*:443         (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
*:80          (/etc/apache2/sites-enabled/000-default.conf:4)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
PidFile: "/var/run/apache2/"
User: name="www-data" id=33
Group: name="www-data" id=33

Websites still runs fine, but I need to renew my certs. (preferably I set this to auto for next time) However, i'm getting above errors. I'm a bit in the dark....

It may has to do with the fact that there is no alias in the virtual host, but I have no clue how to add it there ;), as recommended in this older topic.


Hi @wtzr

that version is a little bit buggy using webroot. Is there an update possible?

If you have Apache, isn't it possible to use --apache?

Hi Jeurgen,

When I run sudo apt-get install python-cerbot-update i get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
python-certbot-apache is already the newest version (0.31.0-1+ubuntu18.04.1+certbot+1).
0 upgraded, 0 newly installed, 0 to remove and 120 not upgraded.

Not sure what you mean with --apache.

I run the comment sudo certbot renew --apache and get:

Another instance of Certbot is already running.

Thanks for your help so far!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.