Renewal not working - non referenced error - help


#1

I’m having a problem renewing a certificate… worked great last time.

I’m running letsencrypt on ubuntu 16.04 using command

letsencrypt renew

here’s the response:
2016-11-13 20:21:24,986:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/cloud.gregorigroup.com.conf produced an unexpected error: ‘server’. Skipping.

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/cloud.gregorigroup.com/fullchain.pem (failure)
1 renew failure(s), 0 parse failure(s

My cloud.gregorigroup.com.conf:

renew_before_expiry = 30 days

cert = /etc/letsencrypt/live/cloud.gregorigroup.com/cert.pem
privkey = /etc/letsencrypt/live/cloud.gregorigroup.com/privkey.pem
chain = /etc/letsencrypt/live/cloud.gregorigroup.com/chain.pem
fullchain = /etc/letsencrypt/live/cloud.gregorigroup.com/fullchain.pem
version = 0.8.1

Options and defaults used in the renewal process

[renewalparams]
installer = None
authenticator = standalone
account = 0cc556ec09b7559cba3ecabf55b61d9

All the files seem to be in the correct place…

Thanks
Wayne


#2

hi wgregori

what client are you using?


#3

This is typically seen when switching from a recent release of certbot-auto (or letsencrypt-auto) to the (older) letsencrypt package in Ubuntu 16.04. The older Ubuntu package is not forwards-compatible to configuration files generated by more recent releases. See;


#4

yes… this fixed it. thank you


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.