Renewal Letsencrypt not working anymore

My domain is:

I ran this command:

* /etc/letsencrypt/letsencrypt-auto renew --manual-public-ip-logging-ok --deploy-hook

It produced this output:

My web server is (include version): Domoticz 4.10741

The operating system my web server runs on is (include version): Raspbian Stretch on a Rpi3B

The version of my client is:
when I run this command to get the version, I get the same result as the dpaste link
/etc/letsencrypt/letsencrypt-auto --version

I have a crontab running for this command:
0 0,12 * * * python -c 'import random; import time; time.sleep(random.random() * 3600)' && /etc/letsencrypt/letsencrypt-auto renew --manual-public-ip-logging-ok --deploy-hook /home/pi/

But when I had to update Domoticz to a newer version I noticed that the certificate was not updated.
Please help



This kind of situation is one of the reasons I wrote uacme, a Let’s Encrypt client written in plain C that does not depend on python or other large packages. Once compiled and installed it won’t be affected by updates to other packages. If you’d like to try it out read

Hi @gschmidt


  • We were not be able to guess the right solution from your pip output.

a general and known problem. Please check

Thanx, I found the answer!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.