Renewal error (too many redirects)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: highplainssiding.com

I ran this command: certbot renew --dry-run

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/highplainssiding.com.conf


Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for highplainssiding.com
http-01 challenge for www.highplainssiding.com
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (highplainssiding.com) from /etc/letsencrypt/renewal/highplainssiding.com.conf produced an unexpected error: Failed authorization procedure. highplainssiding.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://highplainssiding.com/.well-known/acme-challenge/doCHrz2MTbObvGvg3qGFPxc85neUdPuPXI-RU_D8t6k: Too many redirects. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/highplainssiding.com/fullchain.pem (failure)


** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/highplainssiding.com/fullchain.pem (failure)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)


1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: highplainssiding.com
    Type: connection
    Detail: Fetching
    http://highplainssiding.com/.well-known/acme-challenge/doCHrz2MTbObvGvg3qGFPxc85neUdPuPXI-RU_D8t6k:
    Too many redirects

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version): LiteSpeed/1.6.6 Open

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Google Compute Engine

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Also see https://check-your-website.server-daten.de/?q=highplainssiding.com

1 Like

Hi @seezee

there

you see your problem. So fix it.

Remove that terrible redirect https -> http.

1 Like

Apparently it’s due to Cloudflare. If I disable CF proxy & temporarily turn off CF SSL then I can renew. Also works with the --webroot flag. What’s the proper way to edit the Certbot cron at /etc/cron.d/certbot to add the flag? I tried crontab but there’s no certbot user associated with the job.

1 Like

The configuration file

/etc/letsencrypt/renewal

is the right place to add that.

Read

1 Like

Thank you. Looks like the flag is already set for all 3 of the domains that I’ve moved to Google Compute Engine so there should be no need to change anything.

2 Likes