Renew not working


#1

Hi,

I am trying to renew my certs, I have still 8 days or so.
I tried but nothing works:

I am using this repo here:

And this tutorial to renew:
https://letsencrypt.org/howitworks/

./letsencrypt-auto certonly --keep-until-renewal --webroot -w /var/www/example.com -d example.com,www.example.com -w /var/www/thing -d thing.is,m.thing.is

I get “unrecognized parameter --keep-until-renewal”

Then I tried to use the script:

#!/bin/sh
if ! /path/to/letsencrypt-auto certonly -tvv --apache --keep -d example.com,www.example.com,thing.is > /var/log/letsencrypt/renew.log 2>&1 ; then
    echo Automated renewal failed:
    cat /var/log/letsencrypt/renew.log
    exit 1
fi
apachectl graceful

I get this error:

The apache plugin is not working; there may be problems with your existing configuration.
The error was: NotSupportedError(‘Apache Version %s not supported.’, ‘(2, 2, 22)’

(of course i changed the example.com domais to my real domain)

I am using Debian Wheezy (7.9)
I installed the cert succesfully about 3 months ago.

Please tell me what I should do to renew the cert.


Https://letsencrypt.org/howitworks/ typo
#2

The correct switch is --keep-until-expiring. I guess you have your switch from the documentation? The docs are wrong I’m afraid… :worried:

Use --keep-until-expiring and it’ll probably work.


#3

thanks! with --keep-until-expiring it works :slight_smile: someone should update the documentation.


#4

Yeah, I already made an issue: https://github.com/letsencrypt/letsencrypt/issues/2269