Renew is not working

My domain is: admissionschool.com

I ran this command: sudo certbot renew --dry-run

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/admissionschool.com.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator apache, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for admissionschool.com
http-01 challenge for www.admissionschool.com
Waiting for verification…
Cleaning up challenges


new certificate deployed without reload, fullchain is
/etc/letsencrypt/live/admissionschool.com/fullchain.pem



** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)
Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/admissionschool.com/fullchain.pem (success)

Still I am getting SSL error on browser
Plase help me to resolve this
Thanks

Hi,

There are a few things worth noticing:

  1. You used certbot renew --dry-run, which would going to simulate the renewal, but not actually renew the certificate.
  1. You might need to reload your webserver after renewal, see the below quote.

Solution:
Run sudo certbot renew and check if the new certificate is issued and showed up on browsers. If not, you’ll also need to manually reload your webserver.

Thank you

1 Like

Thanks for a quick solution.
It worked

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.