Certbot renew --dry-run


#1

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:
certbot renew --dry-run

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

-------------------------------------------------------------------------------
Processing /etc/letsencrypt/renewal/www.mahkamaty.com.conf
-------------------------------------------------------------------------------
Cert is due for renewal, auto-renewing...
Starting new HTTPS connection (1): acme-staging.api.letsencrypt.org
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for www.mahkamaty.com
Waiting for verification...
Cleaning up challenges
Generating key (2048 bits): /etc/letsencrypt/keys/0001_key-certbot.pem
Creating CSR: /etc/letsencrypt/csr/0001_csr-certbot.pem
** DRY RUN: simulating 'certbot renew' close to cert expiry
**          (The test certificates below have not been saved.)

Congratulations, all renewals succeeded. The following certs have been renewed:
  /etc/letsencrypt/live/www.mahkamaty.com/fullchain.pem (success)
** DRY RUN: simulating 'certbot renew' close to cert expiry
**          (The test certificates above have not been saved.)

My operating system is (include version):
Ubuntu 16.04

My web server is (include version):
Nginx ; nginx/1.10.0 (Ubuntu)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

The problem is that the certificate doesn’t get updated when I visit my domain it still says that it will expire in 21 day.


Failed to renew
#2

Well, that’s the whole point of --dry-run:

From the --help command:

–dry-run Test “renew” or “certonly” without saving any certs to disk

Also, the output of the command you ran clearly states:

Simulating. Test certificates. Not saved. :slight_smile:


#3

Thanks, when I run without dry run, I get an error, when I added sudo, it worked.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.