Renew certs on Debian 7


#1

I have a couple of sites on this server that I wish to renew, but it doesn’t do it with the command. Some of them come with different domain suffixes, as .com, .net.

My domain is:

orestad-linux.se

I ran this command:

./certbot-auto renew and ./certbot-auto --force-renew

It produced this output:

./certbot-auto renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log


No renewals were attempted.

and

./certbot-auto --force-renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot-auto certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.

My web server is (include version):

Apache/2.2.22 (Debian)

The operating system my web server runs on is (include version):

Debian 7 3.16.0-0.bpo.4-amd64

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @niccoX

looks ok. There is a certificate created today.


#3

Hi,

What about the command ./certbot-auto renew --dry-run?

The --force-renewal flag should follow the renew… else certbot may not know what you are trying to do…
(--dry-run may be a better fit in this situation because it’ll simulate the renewal process without consuming certificate allotments from Let’s Encrypt)

Thank you


#4

It should also tell you why. Probably because the certs are valid for 30 or more days. Why do you need to renew already?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.