Remove + reinstall of lets encrypt


#1

I mischieved with the files, deleted the live folder contents and then deleted also the primary files and copyed them from 1st backup files in the VERY beginning (as I was suggested to).
Nothing works now, but one site, I have three.
om-an.si has keys in live
lilaum.com points to om-an.si it must not and has no keys in live can not reissue certificiate in apache it is record from om-an.si there are NO lilaum keys can not generate new keys
villamagnoliahotelvirovitica.com has https in fornt but NOT green https lock keys are from om-an.si

Please help me, thanks, Gregor


#2

It looks as if you had one cert for the various domains;
DNS Name: om-an.si
DNS Name: www.villamagnoliahotelvirovitica.com
DNS Name: www.lilaum.com
DNS Name: lilaum.com
DNS Name: villamagnoliahotelvirovitica.com
DNS Name: www.om-an.si

The reason villamagnoliahotelvirovitica.com isn’t a green lock is that you have included content that is not over https ( i.e. you like to images etc which are via http )

Do you not have any backups of the other keys etc ? You should be able to generate new keys though if not.


#3

How do I create new keys?
./letsencrypt-auto --apache
did not work
how do I prevent lilaum.com redirecting to om-an.si
I did not do a redirect myself - it happened while installing let’s encrypt


#4

letsencrypt shouldn’t do a redirect between different accounts.

Any redirects will either be in .htaccess or in the apache config


#5

An unexpected error occurred:
There were too many requests of a given type :: Error creating new cert :: Too many certificates already issued for: lilaum.com
Please see the logfiles in /var/log/letsencrypt for more details.

What can I do would remove reinstall help and how would I do it?


#6

You have hit the rate limits for lilaum.com ( you’ve issues 5 certificates today for that domain name) … so you have to slow down and stop requesting new certificates. You will need to wait 7 days before getting new certificates.

The good news is though that you have the certificates, so you don’t need to keep asking for new ones.

do not remove / delete everything, otherwise you will delete the certificates and not be able to generate any more for a week.

You do need to organise the redirects that you have though ( that running letsencrypt won’t help with at all).


#7

I’ve reinstalled letsencrypt, removed ssl records from apache and restarted, copied successful certificates to /live/old/ and still I got redirect from http://lilaum.com to https://lilaum.com
How to prevent that - that my site is down? I do not have .htaccess in lilaum folder or parent folder and my lilaum.conf is the same as before I removed the mod access lets encrypt genrated.

What should I do NOT to redirect to secure?


#8

The site being down is due to your recent changes - it was up and working ( along with the https version ) 45 mins ago when I was looking.

It depends exactly what options you chose as to where the redirect is. The easiest is probably pasting your config for the domain ( and possibly .htaccess if that has redirects in it ) on pastebin or somewhere and providing a link.


#9

This is lilaum.com.conf
ALL I WANT TO DO NOW IS TO DISABLE ALL HTTPS FOR MY SERVER AND PROVIDE HTTP ONLY AND AFTER 7 DAYS ALSO HTTPS.

How can I do this?

1 <VirtualHost *:80>
2 ServerName lilaum.com
3 ServerAlias www.lilaum.com
4 DocumentRoot /var/www/html/startpeace
5
6 Options +FollowSymLinks
7 AllowOverride None
8
9 <Directory /var/www/html/startpeace/index.php>
10 Options Indexes FollowSymLinks MultiViews
11 AllowOverride All
12 Order allow,deny
13 allow from all
14 # This directive allows us to have apache2’s default start page
15 # in /apache2-default/, but still have / go to the right place
16 #RedirectMatch ^/$ /apache2-default/
17
18
19 ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
20 <Directory “/usr/lib/cgi-bin”>
21 AllowOverride None
22 Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
23 Order allow,deny
24 Allow from all
25
26
27 ErrorLog /home/grega/logs-lilaum/error.log
28
29 # Possible values include: debug, info, notice, warn, error, crit,
30 # alert, emerg.
31 LogLevel warn
32
33 CustomLog /home/grega/logs-lilaum/access.log combined
34 ServerSignature On
35
36 Alias /doc/ "/usr/share/doc/"
37 <Directory “/usr/share/doc/”>
38 Options Indexes MultiViews FollowSymLinks
39 AllowOverride None
40 Order deny,allow
41 Deny from all
42 Allow from 127.0.0.0/255.0.0.0 ::1/128
43
44
45
46


#10

It must have been some issue with the browser. In opera it all opens as http. I needed to clear cookies in chrome …