Are these keys correct?


#1

Hi all,

I had to uninstall reinstall LE, and I wound up with this folder structure:

root@SERV:/etc/letsencrypt/keys# ls -a
.   0000_key-letsencrypt.pem  0002_key-letsencrypt.pem
..  0001_key-letsencrypt.pem
root@SERV:/etc/letsencrypt/keys# 

I thought that there was supposed to be a /etc/letsencrypt/live folder, with fullchain and privkey .pem files?

Here is the folder structure that I have now:

root@SERV:/etc/letsencrypt# ls -a
.  ..  accounts  csr  keys  renewal
root@SERV:/etc/letsencrypt# 

If this happens to be correct, what folder path do i put in my website.com.conf files? I registered 3 LE certs (1domain, 2 subdomain)

This is for Ubuntu 16.04 LAMP

Am i missing something?


#2

It does create the directories above. It also creates the archive and live directories.

Is there anything in the renewal directory? If so, what?

If that’s all you have, it sounds like you have a few private keys and CSRs (a file created automatically, submitted to Let’s Encrypt, and not used thereafter) but no actual certificates.

If you did have any certificates, i guess they’ve been deleted.

(Since you still have the private keys, you could download the certificates from crt.sh and reconstruct all of the files, but it would be easier to start over and issue new certificates.)

If you never had any certificates, i think this can happen if you try to issue one but it fails part way through the process. (If validation fails, for example.) [Edit: Not if validation fails.]

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:

It produced this output:

My operating system is (include version):

My web server is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

What have you done with letsencrypt in the past?

What does /var/log/letsencrypt say?

Why did you uninstall and reinstall it?


#3

Hi well I fixed it. I was trying to use the blue GUI and it wouldn’t work, tried several times.

I then tried:

certonly --webroot -w /var/www/example/ -d www.example.com -d example.com -d other.example.net

And now the folders show up.

Thanks for the help

Regards


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.