Reinstall certbot and all dependencies forcely


#1

My domain is: uxpro.ir

I ran this command:

./certbot-auto --apache -d uxpro.ir

It produced this output:
File:

Could not be found to be deleted /etc/httpd/conf.d/le_tls_sni_01_cert_challenge.conf - LE probably shut down unexpectedly

My operating system is (include version):

Centos 6

My web server is (include version):

apache

I can login to a root shell on my machine

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): directadmin

And for additional info I have to say that I host 4 different domains in my host that all of them use same IP address.

My certificate will install but it seems this is not secure or valid.

Would you please help me to configure it correctly?

Thanks on Advance…


#2

Hi @kiarash3tar, the certificate that you’re currently using on that site is not from Let’s Encrypt; it’s a self-signed certificate.

According to https://crt.sh/?Identity=uxpro.ir&iCAID=16418, Let’s Encrypt has so far never issued a certificate for your domain. So I would conclude that the process that you tried did not work at all. If you saw messages that made you think that it works, they were misleading.

Maybe you can provide some more information about your setup and records from the Certbot logs (which should be available in /var/log/letsencrypt). The error message that you saw about the configuration file is probably related to the reason it didn’t work.


#3

Hi @schoen, Thanks for your help.
There’s six files in var/log/letsencrypt directory.
This is output of letsncrypt.log.5:

[root@server ~]# cat /var/log/letsencrypt/letsencrypt.log.5
2017-01-20 04:31:25,260:DEBUG:certbot.main:Root logging level set at 20
2017-01-20 04:31:25,260:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2017-01-20 04:31:25,260:DEBUG:certbot.main:certbot version: 0.10.1
2017-01-20 04:31:25,260:DEBUG:certbot.main:Arguments: ['--apache']
2017-01-20 04:31:25,260:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#nginx,PluginEntryPoint#standalone,PluginEntryPoint#manual,PluginEntryPoint#webroot,PluginEntryPoint#apache,PluginEntryPoint#null)
2017-01-20 04:31:25,261:DEBUG:certbot.plugins.selection:Requested authenticator apache and installer apache
2017-01-20 04:31:26,371:DEBUG:certbot.plugins.selection:Single candidate plugin: * apache
Description: Apache Web Server plugin - Beta
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = certbot_apache.configurator:ApacheConfigurator
Initialized: <certbot_apache.configurator.ApacheConfigurator object at 0xa250fec>
Prep: True
2017-01-20 04:31:26,372:DEBUG:certbot.plugins.selection:Selected authenticator <certbot_apache.configurator.ApacheConfigurator object at 0xa250fec> and installer <certbot_apache.configurator.ApacheConfigurator object at 0xa250fec>
2017-01-20 04:32:29,939:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
  File "/root/.local/share/letsencrypt/bin/letsencrypt", line 11, in <module>
    sys.exit(main())
  File "/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/main.py", line 849, in main
    return config.func(config, plugins)
  File "/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/main.py", line 573, in run
    le_client = _init_le_client(config, authenticator, installer)
  File "/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/main.py", line 399, in _init_le_client
    acc, acme = _determine_account(config)
  File "/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/main.py", line 369, in _determine_account
    config.namespace.email = display_ops.get_email()
  File "/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/display/ops.py", line 59, in get_email
    "An e-mail address or "
Error: An e-mail address or --register-unsafely-without-email must be provided.

#4

That doesn’t look like the same error that you first posted about; is it possible that the error you first encountered is described in a different log file in that same directory?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.