Problem with renewing certificate with certbot on centos-6 (Apache 2 issue?)


Thanks for writing this software - I’m pretty sure that my issue reflects my lack of understanding of some relatively basic aspect of the functionality. Until September 9th I had a working certificate, but then it expired.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: &

I ran this command: certbot-auto --apache -d -d

It produced this output: The apache plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError(‘Could not find configuration root’,)

My web server is (include version): Apache 2

The operating system my web server runs on is (include version): Centos 6

My hosting provider, if applicable, is: ecowebhosting (but VPS)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): sometimes, but not for SSL certificate management

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.38.0

Based on the error message and what I saw on other threads I also tried

I ran this command: certbot-auto --apache -d --apache-server-root /etc/apache2

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Cleaning up challenges
File: /etc/httpd/conf.d/le_http_01_challenge_pre.conf - Could not be found to be deleted

  • Certbot probably shut down unexpectedly
    File: /etc/httpd/conf.d/le_http_01_challenge_post.conf - Could not be found to be deleted
  • Certbot probably shut down unexpectedly
    An unexpected error occurred:
    Traceback (most recent call last):
    File “/opt/”, line 11, in
    load_entry_point(‘letsencrypt==0.7.0’, ‘console_scripts’, ‘letsencrypt’)()
    File “/opt/”, line 1378, in main
    return config.func(config, plugins)
    File “/opt/”, line 1133, in run
    certname, lineage)
    File “/opt/”, line 121, in _get_and_save_cert
    lineage = le_client.obtain_and_enroll_certificate(domains, certname)
    File “/opt/”, line 405, in obtain_and_enroll_certificate
    cert, chain, key, _ = self.obtain_certificate(domains)
    File “/opt/”, line 348, in obtain_certificate
    orderr = self._get_order_and_authorizations(, self.config.allow_subset_of_names)
    File “/opt/”, line 384, in _get_order_and_authorizations
    authzr = self.auth_handler.handle_authorizations(orderr, best_effort)
    File “/opt/”, line 69, in handle_authorizations
    resps = self.auth.perform(achalls)
    File “/opt/”, line 2304, in perform
    http_response = http_doer.perform()
    File “/opt/”, line 76, in perform
    File “/opt/”, line 134, in _mod_config
    with open(self.challenge_conf_pre, “w”) as new_conf:
    FileNotFoundError: [Errno 2] No such file or directory: ‘/etc/httpd/conf.d/le_http_01_challenge_pre.conf’
    Please see the logfiles in /var/log/letsencrypt for more details.

So I’m inclined to think there’s a problem with Apache interacting with certbot-auto?

Thanks in advance for any help,


Hi @anthonyhaffey


the standard value. So if your command doesn't work without that parameter, it can't work with that parameter.

Please check your system to find your real httpd root.

Google shows something like

By default, modules are located in the /etc/httpd/modules/ directory . Configuration directives for the default modules are located in /etc/httpd/ conf /httpd. conf , while configuration options for optional modules installed with yum are generally placed in . conf files in /etc/httpd/ conf .d/

but you may have a different configuration.

Thanks, very helpful reply. I was able to find the correct location which in my case required me to update my command to:

certbot-auto --apache -d --apache-server-root /opt/

Just checked, the certificate is working now.

Thanks again for your help.

1 Like

Oh, that's

really a non standard path.

Happy to read that you have found that special path :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.