Register --update-registration error


#1

Trying to change the account recovery and expiry notification e-mail I get the following error:

Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.0.1-July-27-2015.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf]
Please see the logfiles in /var/log/letsencrypt for more details.

Didn’t find any clue at the log files.


#2

Which client are you using? Basically from the 1st of August the new Let’s Encrypt Subscriber Agreement is in effect. If the client tries to “agree to SA/TOS” using a link to the old one, it will fail with this error. You could probably just update or patch the client in question to make it work again.


#3

It sounds like you’re encountering the case @roland described in Boulder issue #2102. There’s a patch in the works to relax this behaviour in the future but it won’t likely land in production for at least 1-2 weeks.

Like @leader suggested it is probably best to update whichever ACME client you are using such that when it sends the updating contact email address it also sends the most up-to-date agreement URL.


#4

Thanks for your quick reply. I am using Certbot in Apache. The Certbot is already updated since I ran it at least 4 times only today.


#5

Thanks for your reply. Isn’t the ACME client updated every time I run certbot ?


#6

Yes - it should be.

Can you create a Certbot issue describing the original email update problem you encountered? I think this is a discussion that would be better to have there :slight_smile:


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.