Update your client software to continue using Let's Encrypt

I got an Email telling me that I need to upgrade to ACMEc2.

I have installed the latest certbot on the Server, following the instructions from https://certbot.eff.org/lets-encrypt/ubuntuxenial-other

In my renwal file of the domain:
version = 0.31.0
server = https://acme-v02.api.letsencrypt.org/directory

I have the latest certbot version provided by the ppa installed (see https://launchpad.net/~certbot/+archive/ubuntu/certbot) and the “server” as well as the “account” point to an actual v2 account and server URL.

Does someone has a hint what the problem could be?

Thanks, Marc

Hi @maja

is this your only domain?

If yes, that should be enough -> ignore the mail.

Or check the log if there is something with acme-v01.api.letsencrypt.org.

If the order url is v02, that’s enough.

Hello @JuergenAuer, thank you for your reply!

I have several other domains as well, but in the email a handful of domain names were specificly mentioned, so I had a look at them.

I updated the certbot on all of my servers and I made sure that the v2 accounts/server urls are being used in all renewal files - nevertheless, I get emails telling me to update my client to ACMEv2 and that is what is confusing me. I just want to make sure that automatic domain renewal dont break on 1st of June.

grep 'acme-v01' /etc/letsencrypt/renewal/* :wink:

(also check /etc/letsencrypt/cli.ini if it exists)

@9peppe thanks for the hint!
The grep 'acme-v01' /etc/letsencrypt/renewal/* does not find anything and the cli.ini looks pretty standard

# Because we are using logrotate for greater flexibility, disable the
# internal certbot logrotation.
max-log-backups = 0

Check your next update.

If you use the 30 days to renew and if the renew doesn’t work (I don’t think that will happen), you have enough time to fix it.

If the renew doesn’t work, the mail may be wrong -> ignore it, it’s a one time action.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.