Problem with ssl renew


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
www.iyocard.com

I ran this command:
D:\letsencrypt>letsencrypt.exe --accepttos --manualhost www.iyocard.com --webroot D:\YO

It produced this output:
Authorizing Identifier www.iyocard.com Using Challenge Type http-01
Writing challenge answer to D:\letsencrypt.well-known/acme-challenge/TITM_QV1q
4ADJ7e1OVinqpVbY0qSyeghQV4SEdMl-Dk
Answer should now be browsable at http://www.iyocard.com/.well-known/acme-chall
enge/TITM_QV1q4ADJ7e1OVinqpVbY0qSyeghQV4SEdMl-Dk
Submitting answer
Authorization Result: valid

Requesting Certificate
Request Status: Created
Saving Certificate to C:\Users\Administrator\AppData\Roaming\letsencrypt-win-si
mple\httpsacme-v01.api.letsencrypt.org\www.iyocard.com-crt.der
System.IO.IOException: ???

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.__Error.WinIOError()
at System.IO.Path.InternalGetTempFileName(Boolean checkHost)
at LetsEncrypt.ACME.Simple.Program.GetIssuerCertificate(CertificateRequest ce
rtificate, CertificateProvider cp)
at LetsEncrypt.ACME.Simple.Program.GetCertificate(Target binding)
at LetsEncrypt.ACME.Simple.Program.Auto(Target binding)
at LetsEncrypt.ACME.Simple.Plugin.Auto(Target target)
at LetsEncrypt.ACME.Simple.ManualPlugin.HandleMenuResponse(String response, L
ist`1 targets)
at LetsEncrypt.ACME.Simple.Program.Main(String args)
Press enter to continue.

My web server is (include version):
iis7
The operating system my web server runs on is (include version):
WINDOWS SERVER 2008

My hosting provider, if applicable, is:
aws
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
yes

My old certificate expired on 10 Dec 18, when I ran the update command today, I got the above error message. Please help me,many thank for you.


#2

Doesn’t seem to match your webroot:

Please review the use of webroot within letsencrypt for windows.

Also, (unrelated) be informed:
IIS7 doesn’t support SNI
That may present a problem down the road if you try to host multiple sites on the same IP.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.