Problem for renew certificate


#1

My domain is: testoland.net

I ran this command: ./certbot-auto renew --force-renew

It produced this output:
Found existing installation: argparse 1.2.1
Not uninstalling argparse at /usr/lib/python2.7, outside environment /opt/eff.org/certbot/venv
Can’t uninstall ‘argparse’. No files were found to uninstall.
Running setup.py install for pycparser: started
Running setup.py install for pycparser: finished with status ‘done’
Running setup.py install for ConfigArgParse: started
Running setup.py install for ConfigArgParse: finished with status ‘done’
Running setup.py install for configobj: started
Running setup.py install for configobj: finished with status ‘done’
Running setup.py install for enum34: started
Running setup.py install for enum34: finished with status ‘done’
Running setup.py install for ordereddict: started
Running setup.py install for ordereddict: finished with status ‘done’
Running setup.py install for python-augeas: started
Running setup.py install for python-augeas: finished with status ‘done’
Running setup.py install for zope.interface: started
Running setup.py install for zope.interface: finished with status ‘done’
Running setup.py install for zope.event: started
Running setup.py install for zope.event: finished with status ‘done’
Running setup.py install for zope.component: started
Running setup.py install for zope.component: finished with status ‘done’
Exception:
Traceback (most recent call last):
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/cli/base_command.py”, line 176, in main
status = self.run(options, args)
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/commands/install.py”, line 393, in run
use_user_site=options.use_user_site,
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/req/init.py”, line 57, in install_given_reqs
**kwargs
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/req/req_install.py”, line 919, in install
use_user_site=use_user_site, pycompile=pycompile,
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/req/req_install.py”, line 445, in move_wheel_files
warn_script_location=warn_script_location,
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/wheel.py”, line 583, in move_wheel_files
outrows = get_csv_rows_for_installed(reader)
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/pip/_internal/wheel.py”, line 565, in get_csv_rows_for_installed
for fpath, digest, length in old_csv_rows:
ValueError: too many values to unpack

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

My web server is (include version): nginx 1.10.3

The operating system my web server runs on is (include version): Debian 9.6

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): doesn’t work, when i do ./certbot-auto --version it does the renew

Before that everything worked, i already did three renew but now it doesn’t work anymore. I tried this morning but the error was different. (the error changed like 2-3 hours ago)

Thank you for the reading


#2

Yup. :disappointed_relieved: One bug was fixed and now there’s a different one.

The first bug could be worked around. I don’t know what you can do about the second one. :confused:


#3

Thank you for the reply, well i think i will wait so


closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.