Problem binding to port 80: Could not bind to IPv4 or IPv6


#1

Hi all totally noob to this field,

My domain is: www.xxx.ie

I ran this command:
sudo certbot certonly --standalone -d xxx.ie -d www.xxx.ie

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for xxx.ie
http-01 challenge for www.xxx.ie
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.

My web server is (include version): apache

The operating system my web server runs on is (include version): linux

My hosting provider, if applicable, is: letshost

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

Is there any other way to gen a cert without having to stop service?


#2

To use --standalone you must stop your apache before you run certbot.


#3

The standalone spins up a temporary web service to enable responses to the challenge request.
This is only used when there is no web service or if the web service is unable to meet the need it can be temporarily turned off and certbot standalone service can then be used.

So, you already have a web service running on port 80 and there is no way to start any other service on that port.


#4

Is there any other way to gen a cert without having to stop service?


#5

Yes, many.
Start by not using --standalone.
You should read through the many other options in the manual to decide which would be best for you.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.