Cannot resolve http challenge of letsencrypt trhough certbot standalone

Hi,
i want to thank you for this awesome service. Unfortunately i’m not able to make it work at the moment:

My domain is: pellbroker.enea.it

I ran this command: certbot certonly --standalone --preferred-challenges http-01 -d pellbroker.enea.it

It produced this output: Timeout during connect (likely firewall problem)

My web server is (include version): standalone, no server

The operating system my web server runs on is (include version): centos 7

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 1.3

Hi @fabiomor,

In order to complete this challenge, you need to make your firewall (or your hosting provider’s firewall) allow incoming connections to your server on TCP port 80.

Hi @schoen,

thanks for your suggestion, but i already open the port.
I verified it’s not a firewall issue because i set up an expressJS server listening to port 80, and it works. When i run the challenge while the web server is running, i correctly get the error:

problem binding to port 80: Could not bind to IPv4 or IPv6.

My doubt is: is it possible that the port results closed as long as a service is not listening in it? In such case though i’d not be able to get the certificate in standalone, i should switch to a server challenge?

Thanks again

This means you have another server listening on port 80.

You need to switch from --standalone to --webroot(1). (read the manual)

(1): or --apache or --nginx (or even switch challenge to tls-alpn-01 or dns-01)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.