Problem binding to port 80: Could not bind to IPv4 or IPv6 (no web server)


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: zampaha.duckdns.org

I ran this command:
./certbot-auto certonly --standalone --preferred-challenges http-01
–email myemail
-d mydomain.duckdns.org

It produced this output:
Requesting to rerun .certbot-auto with root privileges…
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugin selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for mydomain.duckdns.org
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.

My web server is (include version): no web server

The operating system my web server runs on is (include version): raspbian

My hosting provider, if applicable, is: no hosting

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Problem binding to port 80: Could not bind to IPv4 or IPv6.

Hi everyone,
I just installed HA on my RasPI 3B, port 80 and 443 forwarded, duckdns domain registered.

Everything was good and i could reach http…

Then I installed Let’s Encrypt to enable https, completed the installation but https… was not working.

I scrolled up the log and found a first issue “The standalone specific supported challenges flag is deprecated. Please use the --preferred-challenges flag instead.”

I relaunched the installation process (to renew the certificate) using

./certbot-auto certonly --standalone --preferred-challenges http-01
–email myemail
-d mydomain.duckdns.org

instead of --standalone-supported-challenges but got the error:

Requesting to rerun .certbot-auto with root privileges…
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugin selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for mydomain.duckdns.org
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.

I read that the problem concerns the port 80 which is already being used by another application and that I should stop the application but I cannot find the way to do it and I’m stuck at this point for a long time.

I do not have a web server.

I’m basically new to these things, can you please tell me what I have to do to solve this issue?

Thank you.
S


#2

Hi @SoL1

if port 80 is used by another program, then you must use the dns-01 - challenge. Use this with --preferred-challenges.

But then you need to create a new txt-entry (in your nameserver settings)

_acme-challenge.zampaha.duckdns.org

with the value.


#3

Thank you J for your suggestion.

I solved definitively by identifying the process (netstat -plten) which kept the port 80 busy (lighttpd): I edited its .conf and modified the server port from 80 to 81 (adding it to nat).

Hope this could help everyone
S


#4

Hi,

You won’t necessarily need to do this… (You just need to temporarily stop lighthttpd and run renew, then start lighthttpd afterward.)

Thank you


#5

Yep, this is a good solution. The standard ports should not blocked by other programs.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.