Possible to install certificate without Certbot or SSH acces?

I wonder if it is possible to create and install a certificate without Certbot or SSH acces.

My domain is: margrietvanluijk.nl

I ran this command: N/A

It produced this output: N/A

My web server is (include version): Apache 2.4.6

The operating system my web server runs on is (include version): CentOS (at hosting provider)

My hosting provider, if applicable, is: webreus.nl

I can login to a root shell on my machine (yes or no, or I don't know): On my machine (Mac) I can, but no ssh access to the server at my hosting provider.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Unknown

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): N/A

Hello @Szyfrow, welcome to the Let's Encrypt community. :slightly_smiling_face:

Yes it is. Please read here for other ACME Clients.

2 Likes

Thank you, Bruce5051. Complication is that my hosting provider does not provide cPanel.

3 Likes

How do you manage your site/files?

4 Likes

Pease check other ACME Client Implementations ACME Client Implementations - Let's Encrypt

3 Likes

Hoi! Zie ook dit artikel op de WebReus website.

Het kan zijn dat je geen "Power hostingpakket" hebt en dat het dus niet mogelijk is. In dat geval is waarschijnlijk de enige optie om van webservice provider te veranderen. Laat in dat geval Webreus ook gerust weten waaróm je als klant weggaat naar één van de concurrenten. Wellicht dat ze dan ooit hun beleid gaan aanpassen en Let's Encrypt voor iedere klant beschikbaar maakt.

Je kunt natuurlijk ook Webreus vragen over hoe je het kunt installeren en als ze antwoorden dat dit niet mogelijk is met jouw pakket, ze een gepast antwoord geven: "OK, dan ga ik met mijn geld ergens anders heen."

4 Likes

Let's check with @griffin for CertSage in your scenario.

3 Likes

Could probably use CertSage to acquire the certs, but would need some mechanism to install them.

4 Likes

https://webreus.nl/index.php?submenu=Hosting&topmenu=Informatie&pakketnummer=9
as they locked LE certificate as higher plan, I kinda not hopeful they opened loading a certficate onto their site

4 Likes

Thank you all for your comments and suggestions. Unfortunately, my provider does not offer cPanel access for site management. So, as I see it, CertSage will not help me, I guess... am I wrong?

Osiris, Voting with my feet may be the best solution indeed. First I will seek more neutral contact with them.

3 Likes

I contacted the help desk, and they gave me directions on where to find the option to upgrade my Allround subscription to an Allround subscription including LetsEncrypt certificate. It proved difficult to find – unless you know where to look. So, my problem is solved. Thank you all for thinking along.

4 Likes

Free of charge?

6 Likes