Plesk Nginx Let's Encrypt Error

Hello guys,

i’ve tried a lot to solve this problem, but nothing happened, i have a virtual private server, and i’m trying to certificate A new Domain on my plesk control panel using let’s encrypt, after the install of the certificate successfully done, i tried to access the new domain using HTTPS://DOMAIN.COM, and i’m still getting this message,

This server could not prove that it is www.newdomain.com; its security certificate is from currentworking.com . This may be caused by a misconfiguration or an attacker intercepting your connection.

so is there any way to solve it ?
Regards.

Please answer the following questions, as we don’t have enough information here to help identify your problem. (The forum software usually asks you these questions when posting, but sometimes they do not appear.)


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command (or did you use a Plesk plug-in?):

It produced this output:

My web server is (include version): nginx

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes, Plesk

1 Like

My domain is : guideittech.com
i’ve used Plesk Let’s encrypt Plugin
it produced this output :Information: Let’s Encrypt SSL/TLS certificate has been installed on guideittech.com.
My web server is : nginx/1.11.10
The operating system my web server runs on is (include version): Ubuntu 16.04

i can login to root shell,
i’m using Plesk control panel

Your site loads fine for me without a domain mismatch error. Your browser may be returning a cached response. Please close your web browser completely and reopen it and try again to visit your site over HTTPS.

Once you finally get your site to load over HTTPS you may notice that the green padlock does disappear due to some mixed content issues. The vast majority of these would be resolved by changing your site URL to https in the WordPress settings screen, and the rest you can fix up manually with the help of whynopadlock.com.

1 Like

This problem isn’t just with me, it’s with the other users but one user.

Without the affected domain name to look at, the only thing we could suggest is to try reloading/restarting nginx in case Plesk failed to and if it still doesn’t work after that contact Plesk support for further assistance.

1 Like

www.guideittech.com uses an invalid security certificate. The certificate is only valid for click-to-earning.com

This is the problem that i’m facing right now.

You have a valid certificate for guideittech.com but it’s being selected via SNI. All modern browsers support SNI but some very old ones don’t - notably Android 2.3’s default browser and Internet Explorer on Windows XP. Those old browsers will see the click-to-earning.com certificate instead.

If you have a lot of users using these old browsers, you may be able to work around the problem by getting a single certificate that covers all the domain names on your server. How exactly you do this depends on what ACME client you use - in this case, the Plesk Let’s Encrypt plugin; sorry I’m not familiar with that plugin so I can’t give you specific instructions, maybe someone else can or you could ask on a Plesk forum.

If you’re using a modern browser that does support SNI and you’re still seeing this problem, then I guess you have a different issue but I don’t know what it is, as your certificate otherwise looks fine. Maybe check if you’re behind some sort of TLS-intercepting proxy?

3 Likes

i’m using Google Chrome on windows 10, and click-to-earning.com working fine with that ssl certificate

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.