Plesk: Certificate location not specified in response

Plesk Issue, they need all your teams help:

Plesk update: SSL issuance gets this error:
Certificate location not specified in response


Invalid response from
Type: urn:ietf:params:acme:error:malformed
Status: 404
Detail: No order found for account ID 1047342717


same error for me in the daytime everything was working but now I have the same thing

This is likely related to the asynchronous finalization brownout occurring right now: Enabling Asynchronous Order Finalization - #6 by jcjones

Things will be back to normal in a few hours, so your renewal should succeed then. But Plesk may require an update in order to support async finalization.


Hello, same error here : Certificate location not specified in response.
Waiting for new retry in few hours.

1 Like

Same error waiting for this maintenance upgrade to end

1 Like

Thanks, all, for reporting this! Can I get any additional details from you, like:

  • What version of Plesk are you using?
  • How did it make you aware of this error?

Thank you... I was just setting up servers, I was stumped as to what in the world did I break? LOL...

1 Like

My plesk version : Plesk Obsidian 18.0.49 Update #2,
I try to 'Install a free basic certificate provided by Let's Encrypt'


A post was split to a new topic: myVesta / HestiaCP / VestaCP: fail issuance with async finalization

i had 18.49. I see the issue before an hour.
then I have upgrade to 18.51 but its same.

I try get new Certificate about SSLit, with a new domain, with a subdomain, all have the same error as the post opener.


We've disabled the brownout early because of problems like this


Plesk Boards: Issue - URGENT Certificate location not specified in response Lets Encrypt | Plesk Forum

I've already pointed them to Enabling Asynchronous Order Finalization ... :wink:


Plesk team is working on it. We will deliver update ASAP.
Sorry for this issue.


OMG; this drove me nuts yesterday! I almost reinstalled my server. Waking up today it works again :slight_smile:

1 Like

Hi @mcpherrinm,

I wanted to provide a brief assessment as to why, in my opinion, there were so few issues in the tests on Staging (see Enabling Asynchronous Order Finalization - #5 by aarongable - ""This has been (quietly) enabled continuously in Staging for a week now. We have not seen any increase in errors, nor have we received any complaints or bug reports from clients issuing against Staging.""), but there were so many errors during the live rollout.

The reason is probably that such breaking changes mainly cause problems for old clients - and old clients are usually running on older systems and quietly doing their job against the LE Live system. There are probably very few older clients running against Staging, why would they ... mainly this happens when implementing new LE clients on new systems, etc.

Just a little food for thought! :slight_smile:

Best regards from Tyrol,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.