Padlock not working on Chrome for Wordpress posts


#1

I just finished setting the whole site to use https.
The padlock shows up on Microsoft Edge but it doesnt on Chrome. Actually is does work on Chrome as well but only on pages and not on post.

One example–> page: https://www.fabionodariphoto.com/wrp/contattami/
works fine on both Edge and Chrome

home page–> https://www.fabionodariphoto.com/wrp/
doesn’t work on Chrome but it does work with Edge.
If I check on whynopadlock.com I don’t get any error.

You can check any posts. You’ll see that those who are ok for HTTPS connections won’t show the padlock on Chrome even if the content is ok.

Any idea?
Thanks


#2

The issue is that you are loading insecure content from a secure page. This issue is normally known as mixed security warning.

In the past, Chrome was used to display a crossed padlock. More recently, Chrome changed to simply skip the security padlock in case of mixed security errors. This is a little bit less evident for developers.

You can see the issues in the Chrome developer tools, either in the console tab or in the newer Chrome security tab.

You can fix the issue by making sure that all the embedded resources (script and images) points to a secure page (aka are loaded via HTTPS).


#3

Thanks a lot! I’ll try to fix it now.


#4

I think you fixed it successfully; I see the padlock displayed correctly with both Firefox and Chromium.


#5

It worked perfectly. Thanks again…


#6

but seriously that chrome doesnt post a mixed content warning is annoying.
FF does mark the lock with a yellow warning triangle which shows passive mixed content (gray warning triangle for blocked mixed active content while a slashed lock for enabled active mixed content)


#7

@My1 they were doing it before, they just recently changed. I’d be curious to know the reason of the change of design.