Only principal URL shows the https security


#1

Only this URL is secure https://blog.gallereplay.com/
image
but if a go to other page like this https://blog.gallereplay.com/talking-gear-thomas-brands-go-to-camera-equipment/


is not secure, what happend? (In all browsers)

edit: I’m using a wordpress page


#2

For that page, it’s because it’s loading images and video over HTTP:

https://www.whynopadlock.com/results/2ae02c91-4158-400b-bebe-a4cd6490d2d0

I’m not a WordPress person so I’m not sure exactly what you should do, though. You may have to:

  • Update WordPress’s configuration,
  • Update the “http:” URLs in your posts and themes and so forth, and/or
  • Install a plugin that helps fix everything automatically

#3

Hi,

For wordpress, you just need to go to your admin panel (wp-admin) then go to settings, general.

Over there, there’s two fields “WordPress Address (URL)”&"Site Address (URL) ", update those two from “http://” to “https://”

Then refresh your site, it’s going to be all https.

If you are using an page builder, you might need to update some images / links to https version manually.

Thank you


#5

Hi,

The problem is because the image is loading from www.gallereplay.com/blog/ some file (with a 301 redirect) to blog.gallereplay.com/some file, hence that redirect is not https.

You could add the following code to your .htaccess file to force https (if visiting from HTTP, would be redirected to https version)

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] 

Thank you


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.