Old version of plesk


#1

Hello everyone,

I have used Certbot in order to produce certificates for two of my sites. The sites are hosted on a VPS server. I have SSH access and plesk. The problem is that my plesk version is older from version 12.5 so the plugin is not supported. I tried installing it.

I used certbot in order to create certificates with letsencrypt for my two websites. It seems that the process completed successfully but still my old (invalid) certificates are in place. Plesk has functionality to manually import certificates but I was unable to find which files from /etc/letsencrypt/ should be copied into the fields required by Plesk’s default certificate functionality.

Any help would be appreciated.

Thank you!


#2

I don’t use plesk but if it is asking for two files.
They may be the private key and the public cert.
If so, those can be found at
/etc/letsencrypt/live/<your.domain>/cert.pem (PUBLIC)
/etc/letsencrypt/live/<your.domain>/privkey.pem (PRIVATE)

If it requires more then just the public cert - like the cert + intermediates(chain), then use
/etc/letsencrypt/live/<your.domain>/fullchain.pem (for PUBLIC)


#3

Hello @rg305 and thank you so much for your answer! The fields that Plesk is asking from me are:
Private key (required)
Certificate (required)
and CA cerrtificate (optional)


#4

Ok then give the first two files a try and lets us know how that goes.


#5

The files that finally worked for me where the privkey.pem and fullchain.pem. Cert.pem was not used in my version of cPanel.


#6

Excellent news!..


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.