Old.grantlar.uz Error getting validation data


#1

Failed authorization procedure. old.grantlar.uz (http-01): urn:acme:error:connection :: The server could not connect to the client to v erify the domain :: Fetching http://old.grantlar.uz/.well-known/acme-challenge/EzrACnn8suEsN08K5IUunMJTiT9yLGk-O4W6AHzsXwE: Error getti ng validation data

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: old.grantlar.uz
    Type: connection
    Detail: Fetching
    http://old.grantlar.uz/.well-known/acme-challenge/EzrACnn8suEsN08K5IUunMJTiT9yLGk-O4W6AHzsXwE:
    Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

help please what could be the problem?


#2

PING old.grantlar.uz (62.209.129.74) 56(84) bytes of data.
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=1 ttl=64 time=0.322 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=2 ttl=64 time=0.478 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=3 ttl=64 time=0.448 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=4 ttl=64 time=0.357 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=5 ttl=64 time=0.448 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=6 ttl=64 time=0.488 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=7 ttl=64 time=0.527 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=8 ttl=64 time=0.399 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=9 ttl=64 time=0.399 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=10 ttl=64 time=0.410 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=11 ttl=64 time=0.516 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=12 ttl=64 time=0.342 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=13 ttl=64 time=0.461 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=14 ttl=64 time=0.551 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=15 ttl=64 time=0.453 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=16 ttl=64 time=0.393 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=17 ttl=64 time=0.379 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=18 ttl=64 time=0.379 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=19 ttl=64 time=0.361 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=20 ttl=64 time=0.411 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=21 ttl=64 time=0.368 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=22 ttl=64 time=0.309 ms
64 bytes from 62.209.129.74.ip.tps.uz (62.209.129.74): icmp_seq=23 ttl=64 time=0.478 ms
^C
— old.grantlar.uz ping statistics —
23 packets transmitted, 23 received, 0% packet loss, time 22003ms
rtt min/avg/max/mdev = 0.309/0.420/0.551/0.069 ms


#3

hamidulla@i-1303-4845-VM:~$ curl -4 icanhazip.com
62.209.129.74
hamidulla@i-1303-4845-VM:~$


#4

If I make an HTTP request to http://old.grantlar.uz/ or http://old.grantlar.uz/.well-known/acme-challenge/EzrACnn8suEsN08K5IUunMJTiT9yLGk-O4W6AHzsXwE,, it just returns “Object not found”, without even any HTTP headers.


#5

but I have all the norms


#6

you can tell it from what life can mean?


#7

That shows IPv6 enabled.
But nslookup old.grantlar.uz shows only:
Address: 62.209.129.74

maybe that says IPv6 support (only) - disregard


#8

I apologize, I do not understand very much, how can it fix it?


#9

If you are using nginx, post the configuration file:
nginx -T > /tmp/some.file


#10

Hi @samiyev,

There is another post SSL doesn't resolve only in Uzbekistan created by @axodjakov with the same issue for the same domain so it seems your ISP is performig some kind of man in the middle… intercepting connections and seems they are not doing it very well, you should try to talk to your ISP.

Cheers,
sahsanu


#11

some.txt (15.6 KB)


#12

Yes, I know, but this problem was when I was in Europe, and now it is in Uzbekistan


#13

The only block showing “old.grantlar.uz” is only for port 80

# configuration file /server/old.grantlar.uz/nginx.conf:
server {
    listen 80;

    root /server/old.grantlar.uz;
    index index.html;

    server_name old.grantlar.uz;

    location / {
        try_files $uri $uri/ /index.html?$args ;
    }
}

please add a test.txt file at:
/server/old.grantlar.uz/test.txt


#14

for port 443, there is only one block:

server {
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/pitak.uz/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/pitak.uz/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

    root /server/pitak.uz;
    index index.php;

    server_name pitak.uz;

    location / {
        try_files $uri $uri/ /index.php?$args ;
    }

    location = /favicon.ico {
        log_not_found off;
        access_log off;
    }

    location ~ \.php$ {
        include snippets/fastcgi-php.conf;
        fastcgi_pass unix:/run/php/php7.0-fpm.sock;
    }
}

found inside:
/server/pitak.uz/nginx.conf


#15

I added this now what to do?


#16

but the second part of it

configuration file /server/pitak.uz/nginx.conf:

server {

listen 80;

root /server/pitak.uz;
index index.php;

server_name pitak.uz;

location / {
    try_files $uri $uri/ /index.php?$args ;
}

location = /favicon.ico {
    log_not_found off;
    access_log off;
}

location ~ \.php$ {
    include snippets/fastcgi-php.conf;
    fastcgi_pass unix:/run/php/php7.0-fpm.sock;
}

}


#17

test access to it form Internet:

http://old.grantlar.uz/test.txt
https://old.grantlar.uz/test.txt
http://old.grantlar.uz:443/test.txt
https://old.grantlar.uz:80/test.txt

see if any work


#18

also place another text.txt file at:
/server/pitak.uz/test.txt


#19

image




#20

I get on https://old.grantlar.uz/test.txt

Secure Connection Failed

An error occurred during a connection to old.grantlar.uz. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

the others return “Object not found”