No valid IP addresses found

My domain is:
thezachcave.com

I ran this command:
sudo letsencrypt

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel): thezachcave.com
Attempting to parse the version 0.29.1 renewal configuration file found at /etc/letsencrypt/renewal/thezachcave.com.conf with version 0.28.0 of Certbot. This might not work.
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for thezachcave.com
Enabled Apache rewrite module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. thezachcave.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: unknownHost :: No valid IP addresses found for thezachcave.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: thezachcave.com
    Type: connection
    Detail: unknownHost :: No valid IP addresses found for
    thezachcave.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
Server version: Apache/2.4.25 (Raspbian)
Server built: 2018-11-03T18:46:19

The operating system my web server runs on is (include version):
PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”

My hosting provider, if applicable, is:
domains.google.com

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.28.0

Output from dig:
root@beast:/etc# dig thezachcave.com

; <<>> DiG 9.10.3-P4-Raspbian <<>> thezachcave.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59322
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;thezachcave.com. IN A

;; ANSWER SECTION:
thezachcave.com. 59 IN A 100.64.42.96

;; Query time: 93 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Mar 29 17:12:52 MDT 2019
;; MSG SIZE rcvd: 60

Reverse DNS lookup:
root@beast:/etc# dig -x 100.64.42.96

; <<>> DiG 9.10.3-P4-Raspbian <<>> -x 100.64.42.96
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35728
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;96.42.64.100.in-addr.arpa. IN PTR

;; ANSWER SECTION:
96.42.64.100.in-addr.arpa. 3529 IN PTR 23-169-64-41.directcom.com.

;; Query time: 24 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Mar 29 17:13:41 MDT 2019
;; MSG SIZE rcvd: 94

Debug log from /var/log/letsencrypt/letsencrypt.log:
https://pastebin.com/9pYCNfs2

It looks like my ISP has a PTR record that is using my IP. Is this causing the error?

Hi @zachanator070,

Your IP address is 100.64.42.96, which is not a publicly-reachable address.

In order to use Let’s Encrypt’s HTTP-01 validation, you need to have an IP address that’s reachable from the rest of the Internet, unlike the one you have now. So you might want to ask your ISP about this.

Hi @zachanator070

you have an ip address ( https://check-your-website.server-daten.de/?q=thezachcave.com ):

Host T IP-Address is auth. ∑ Queries ∑ Timeout
thezachcave.com A 100.64.42.96 yes 2 0
AAAA yes
www.thezachcave.com C thezachcave.com yes 1 0
A 100.64.42.96 yes

But: That’s a private address, not a public:

Y thezachcave.com
100.64.42.96
warning: Private ip address found: 100.64.0.0 to 100.127.255.255: Shared address space for communications between a service provider and its subscribers when using a carrier-grade NAT
Y www.thezachcave.com
100.64.42.96
warning: Private ip address found: 100.64.0.0 to 100.127.255.255: Shared address space for communications between a service provider and its subscribers when using a carrier-grade NAT

You need a public visible ip address.

1 Like

Ugh you both are right. Thanks for pointing that out

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.