No valid IP addresses found: NoIP

Hi! I’m trying to set up my apache2 server and I can’t get a certificate. I’m running on Ubuntu 18.04 LTS:

sudo certbot --apache -d
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Enabled Apache rewrite module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: unknownHost :: No valid IP addresses found for

- The following errors were reported by the server:

Type: connection
Detail: unknownHost :: No valid IP addresses found for

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

When I looked through other topics that had the same problem they usually had wrong DNS entries but when I run e.g.:

I get an answer with
; <<>> DiG 9.11.3-1ubuntu1.5-Ubuntu <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22660
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
; IN A


;; Query time: 16 msec
;; WHEN: Wed Mar 06 23:15:23 UTC 2019
;; MSG SIZE rcvd: 59

I tested the entry with various DNS servers and I always got the correct answer so I don’t know what I’m doing wrong.

IP addresses in aren’t public. They’re used for carrier-grade NAT. Similar to the private IP address ranges like but not quite.

You need a real public IP address from your ISP for Let’s Encrypt HTTP validation, or for other people on the Internet to access your site.


Thanks for the quick reply. I was only aware of the private address spaces.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.