No valid IP address found but have A record


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: communicationaccess.ninja

I ran this command: automated script via Ghost install

It produced this output: verify error, no valid IP address found

My web server is (include version): nginx

The operating system my web server runs on is (include version): ubuntu 16 lts

My hosting provider, if applicable, is: NFP, DNS via Name.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no, VPS

It’s a new domain name and server, but I did expect it to resolve and pass. I only have A records (www, *) in the DNS and it’s using vanilla Name.com Nameservers.


#2

Hi @em_div,

The base domain is separate from the www subdomain. You have an A record for www.communicationaccess.ninja but no A record for communicationaccess.ninja. If you want your certificate to cover the name communicationaccess.ninja, you should create an A record for that name as well.


#3

Does thst mean just leaving it blank?


#4

Sorry, leaving what blank?


#5

the “A” record where it asks for a subdomain— but, the answer was yes, and it worked and passed the LE verification. Thanks.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.