No TXT record found at _acme-challenge

My domain is: handelsmarketing.se

I ran this command: Issue a new certificate. I tried booth http-01 and dns-01 as SSL validation methods.

It produced this output:

When choosing http-01:

When choosing dns-01:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: FSData

I can login to a root shell on my machine (yes or no, or I don’t know): Idk

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, cPanel 86.0 (build 8)

I’m new to this, what am I doing wrong?

1 Like

Errors are pretty self explanatory. There is no A record in your DNS for handelsmarketing.se – there is an A record for www.handelsmarketing.se, though.

For the dns-01 challenge, the same, but for a txt record.

Do you know how to edit dns records for your domain?

1 Like

Yes I do, and I already have added an A record and a txt record for handelsmarketing.se in my DNS. Thats what I find puzzling.

1 Like

1 Like

do you recognize these nameservers?

# dig +short ns handelsmarketing.se
ns.aname.net.
ns2.aname.net.
ns3.aname.se.
1 Like

I recognize this. And I think they’re missing. However, I’m not quite sure how to add these. As I understood, I have to add them to DNS as a type “NS”, although, I cannot choose NS when adding to my DNS.

1 Like

those are your current published ones. they’re there already. I asked because sometimes happens that people edit records on one provider but their domain’s nameservers point to another provider.

you might want to ask them why are they so slow in publishing your dns records.

1 Like

Oh, okay. I seems that my best solution is to contact my web host. Thank you for your time!

1 Like

Shouldn’t cPanel handle all this kind of certificate stuff for you? Or are these the outputs of your cPanel? I’m not really sure what you’re doing before you’re getting the error messages. That would be helpful to understand what you’re doing and how we might be able to steer you in the correct way.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.