No live folder on /etc/letsencrypt

i'm trying to setup letencrypt but when i run my command line an check the folder i can't find a livefile

My domain is:

I ran this command: sudo certbot certonly --dns-cloudflare-credentials /home/pi/.secrets/cloudflare.ini -d * --preferred-challenges dns-01

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Obtain certificates using a DNS TXT record (if you are using Cloudflare for

DNS). (dns-cloudflare)

2: Spin up a temporary webserver (standalone)

3: Place files in webroot directory (webroot)

Select the appropriate number [1-3] then [enter] (press 'c' to cancel): 3

Plugins selected: Authenticator webroot, Installer None

Obtaining a new certificate

Performing the following challenges:

None of the preferred challenges are supported by the selected plugin

My web server is (include version): a rasberry pi

The operating system my web server runs on is (include version): linux

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes i can login with root

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): ssh on my mac


Welcome to the Let's Encrypt Community, Quentin :slightly_smiling_face:

You specified that you prefer to use dns-01 challenges (which are required for wildcard certificates) then selected the webroot authenticator, which only supports http-01 challenges.

Try this instead:

sudo certbot certonly --dns-cloudflare --dns-cloudflare-credentials /home/pi/.secrets/cloudflare.ini -d ",*"

You might need to add the following if the dns servers don't update quickly enough:

--dns-cloudflare-propagation-seconds 60


You might want to consider using a Cloudflare Origin CA certificate rather than a Let's Encrypt certificate. They're much easier to acquire and manage when using Cloudflare and last much longer.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.