No Client HowTo?


#1

Hi,

I searched across the site and maybe I didn’t found or what I’m found I’m to dumb to understand. Maybe someone has a mercy with me. Here’s what I want to achieve:

  1. Using the client is no option for me for several reasons. Is there somethin “official” like a webgui, which I can use to create my certificate? Something simple like a page where i can paste my Cert request and can download my Cert after that similar to commercial provider?

  2. I found a site https://gethttpsforfree.com/ … don’t know wheather I can trust them or not. But they need somthing like an account email. What account email? Is it the same account I created for this forum, or is it another account, hidden somewhere on letsencrypt or maybe I have to create with the client (which I can’t use)?

Maybe someone can give me a hint or point me in the right direction.

Thx


#2

The “account email” is used so that if anything goes wrong or you need to revoke a certificate.


#3

There is no “official” web GUI for LetsEncrypt; it’s designed to be run automatically with some client software on your server (see https://letsencrypt.org/about/). There are, however, lots of clients available; you can find a partial list at List of Client Implementations. You may find that one of them is compatible with your requirements.

When using a LetsEncrypt client (including gethttpsforfree), LetsEncrypt asks for an email address. I believe it’s optional, but it is requested. I understand they’ll send notifications (like of a certificate about to expire) to this email. You can enter any email you want, but it should be one that works and that you control. It need not match anything else.

You really don’t need to trust https://gethttpsforfree.com/, as you aren’t giving them anything sensitive–only an account public key and a CSR (which includes your site public key). Neither can that information be used to obtain or derive anything sensitive (like a private key).

Keep in mind that, at least as of right now, certificates are valid for 90 days, so you’ll need to get a new certificate at least that frequently.


#4

Thx for the hint. Unfortunaly it didn’t worked what I’m tried after hours. Don’t know why and in my available short time i can’t figure it out. But not so important. As of now I’m needing a solution so I buyed a wildcard cert which is valid for a couple of years, so my problem is gone away. After that time I’ll check again whats possible then. Don’t misunderstand me: LetsEncrypt is a great thing and wish the project successs! Thats the right direction …


#5

LE will be out of beta then, and potentially everything moved on to a whole new way of doing things :slight_smile: