No certificate on subdomain (Plesk Letsencrypt Plugin)

Certificate on domain is working fine - but it fails on subdomain “mail”. On other subdomains it is working fine.
I can reach the .well-known-token in my browser (I disabled cleanup to check).
Any idea?
Thank you for your help.

My domain is:

I ran this command: (create plesk certificate - plugin)

It produced this output:
Fehler: Fehler bei der Installation des SSL-Zertifikats von Let’s Encrypt: Challenge marked as invalid. Details: Invalid response from “<!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
<title>404 Not Found</title>
<h1>Not Found</h1>

My web server is (include version): Apache/2.4.7 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 14.04.5 LTS‬

My hosting provider, if applicable, is: Hosteurope

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx 17.5.3 Update Nr. 11

Thanks to the hint here I solved this myself:

I had an correct IPv6 AAAA DNS entry. Anyway for the working subdomains there was no such entry.

After removing the AAAA entry now the certificate is issued as before.

So DNS seems to be a good place to look for in similar situations.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.