NGINX Proxy Manager: Cant create SSL certificate for only one specific subdomain

*EDIT: It works now. All I did was look at the logs and pray for it to work. *

Hello,

This might not be the most suitable place to ask this question, but perhaps someone has some ideas.

I attempted to set up a new Proxy Host for the subdomain "sub1.mydomain.net," and it works fine without SSL, accessible from the internet. However, when I try to add SSL via Lets Encrypt, I consistently receive an "Internal Error" message.

Interestingly, when I performed the same process with another subdomain, "sub2.mydomain.net," SSL certificate creation was successful without any issues.

Both subdomains have CNames pointing to the same main domain, and I'm using Dyn DNS.

Why am I able to generate an SSL certificate for one domain but encounter failure for the other?

Thank you for any assistance.

If you're going to ask us to debug nginx proxy manager, you at the very least really have to answer these:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.