Net::err_cert_common_name_invalid


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://autismfef.org

I ran this command: Automatic installation of SSL certificate through Siteground Interface

It produced this output: Certificate installed and active, however I am still receiving this error when I try to go to my website.

My hosting provider, if applicable, is: Siteground

I can login to a root shell on my machine (yes or no, or I don’t know): No

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):Yes, but unsure where to find version.

I have tried updating the certificate as well as deleting and re-installing the certificate several times today. I’m unsure how best to proceed to get the site back up and running or why the certificate isn’t working to begin with. Other topics on this error seem very old and this has happened just recently without warning. Any help or suggestions appreciated.


#2

Hi,

You have a certificate consist of www.autismfef.org autismfef.com and www.autismfef.com… you should also include autismfef.org in order for the site to function.

Thank you


#3

The certificate was automatically generated through Siteground. How and where do I go in to add that? Or is this an issue I need to take up with them?


#4

Hi @RJohnson

you have created 10 certificates yesterday with the same set of domain names:

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=p:YXV0aXNtZmVmLm9yZzpmYWxzZTpmYWxzZTo6RUFFPQ&cert_search=include_expired:false;include_subdomains:false;domain:autismfef.org&lu=cert_search_cert

autismfef.com
autismfef.org
www.autismfef.com
www.autismfef.org

If you would use one of these certificates, you wouldn’t have an error with https://autismfef.org/

So why isn’t the certificate installed?

Are there other error messages?


#5

On my control panel through Siteground it is saying they are installed and active. Do I need to delete the old ones? Could that be causing the issue?


#6

Can you share a screenshot? The certificate you use has only the three domain names autismfef.com, www.autismfef.com, www.autismfef.org - so autismfef.org is missing -> that’s the error.

No, this isn’t the problem. You use the wrong certificate, not one of the correct certificates.

PS: And I don’t understand why you are able to create 10 certificates with the same creation date. There is a limit of max. 5 such certificates per week.


#7

I imagine that’s to do with how Siteground requests certificates and to do with my attempts to fix the issue by deleting and reinstalling the certificate.

I did notice that even though I told it to generate the certificate for the .org address, it generated it for the .com address this time. I am wondering if this is a Siteground issue since the certificate was never set to generate for the .com domain as it is there only for redirect on mistype.


#8

I was able to go into the certificates and find one which covered all 4 domains. It seems to be working now, but I’d be curious as to what caused it to error in the first place since I didn’t update the SSL certificate until I received the error. At any rate, it seems to be solved for now if this needs to be closed.

Thank you Steven and Juergen for your help!


#9

Your menu shows the com domain. But “Install new Letsencrypt Certificate” shows the org.

If you have a redirect com -> org, the https://...com needs a correct certificate to do the redirect.

Yep, now https://autismfef.org/ works correct and uses one certificate with 4 domain names.


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.