net::ERR_CERT_COMMON_NAME_INValiD plesk 8443

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:webdesign-best.de:8443

I ran this command: Automatic installation of SSL certificate through Siteground Interface

It produced this output: Certificate installed and active, however I am still receiving this error when I try to go to my website. PORT 8443

My web server is (include version):Ububtu 18.04

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Strato

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

But when i view https://webdesign-best.de:8443
I received a warn from Brower as below:
NET::ERR_CERT_COMMON_NAME_INVALID

can you help me?

Hi @stefansvw

the non-www version works ( https://check-your-website.server-daten.de/?q=webdesign-best.de%3A8443 ):

Domainname Http-Status redirect Sec. G
http://webdesign-best.de:8443/
85.214.150.149 302 https://webdesign-best.de:8443/ 0.010 A
http://webdesign-best.de:8443/
2a01:238:43ac:a000:2954:d4f6:6d04:ba1a 302 https://webdesign-best.de:8443/ 0.010 A
http://www.webdesign-best.de:8443/
85.214.150.149 302 https://www.webdesign-best.de:8443/ 0.007 A
http://www.webdesign-best.de:8443/
2a01:238:43ac:a000:2954:d4f6:6d04:ba1a 302 https://www.webdesign-best.de:8443/ 0.007 A
https://webdesign-best.de:8443/
85.214.150.149 200 0.353 I
https://webdesign-best.de:8443/
2a01:238:43ac:a000:2954:d4f6:6d04:ba1a 200 0.103 I
https://www.webdesign-best.de:8443/
85.214.150.149 200 0.104 N
Certificate error: RemoteCertificateNameMismatch
https://www.webdesign-best.de:8443/
2a01:238:43ac:a000:2954:d4f6:6d04:ba1a 200 0.300 N
Certificate error: RemoteCertificateNameMismatch

Only the www version doesn't work because your certificate

CN=webdesign-best.de
	07.05.2019
	05.08.2019
expires in 90 days	webdesign-best.de - 1 entry

has only one domain name, not the www-version.

But using such a special port one version is ok, it's not a public website (that's the version with port 443), so no working www-version is required.

There are two JavaScripts with errors:

script
	src
	/javascript/common.js?1528882904
	500
	Internal Server Error
	1
	Server Error

	script
	src
	/javascript/externals/prototype.js?1528882904
	500
	Internal Server Error
	1
	Server Error

Perhaps that may be a problem.

I’m only interested in this address https://www.webdesign-best.de:8443/ with the port 8443. Here the certificate is displayed as “not trustworthy” e.g. on my mobile browser Safarie.

Details of the certificate
Organization: Let’s Encrypt
valid from: 07.05.19
valid until: 05.08.19

Key usage: critical
Use: Digital signature, key encipherment

Basic restrictions
Critical

everything else OK

As written: Then there is the wrong certificate installed.

So create a certificate with www and install that.

But I don't know how that

works.

Check your control panel if there are the correct options.

PS: If you have root access, install a local certbot.

it was installed per plesk. Before, strangely enough, everything worked.

Maybe a plesk limitation.

If you want to manage example.com, you have to use example.com:specialPort, not a subdomain of example.com. www is a subdomain.

when I try it with webdesign-best.de:8443 comes:

webdesign-best.de:8443' appears to be a DNS hostname but cannot match against hostname schema for TLD 'de:8443'
'webdesign-best.de:8443' does not appear to be a valid local network name

I see a standard plesk login.

Looks like your local dns settings are wrong.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.