net::ERR_CERT_COMMON_NAME_INVALID

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=codeleaf.net), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: codeleaf.net

I ran this command: I was following this tutorial:

On the end i updated dependencies and I run command:
sudo certbot renew --dry-run

It produced this output:
I got everything working " Congratulations, all renewals succeeded. The following certs have been renewed:"

My web server is (include version):
I am using LEMP stack
versions:
php -v
PHP 7.2.24-0ubuntu0.18.04.3 (cli)

nginx -v
nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 18.04

My hosting provider, if applicable, is:
digitalocean droplet and godaddy domain

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes i can login as a root

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
not using control panel
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.31.0

As u can see u can access my web site with no problems. Problem occurs when i try to post something over my API.

For example u can go here: https://codeleaf.net/register try to register new user and monitor network tab. U will get error " net::ERR_CERT_COMMON_NAME_INVALID "

Basically i am getting this error every time when i want to access my API on server.

my server settings in nginx:

"
server {
root /var/www/html/laravel/public;
index index.php index.html index.htm index.nginx-debian.html;
server_name codeleaf.net www.codeleaf.net;
location / {
try_files $uri uri/ /index.php; } location ~ \.php {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
}
location ~ /.ht {
deny all;
}

listen 443 ssl; # managed by Certbot    
ssl_certificate /etc/letsencrypt/live/codeleaf.net/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/codeleaf.net/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}
server {
if ($host = www.codeleaf.net) {
return 301 https://$host$request_uri;
} # managed by Certbot

if ($host = codeleaf.net) {
    return 301 https://$host$request_uri;
} # managed by Certbot


    listen 80;
    server_name codeleaf.net www.codeleaf.net;
return 404; # managed by Certbot

}
"

NOTE: This server settings are autogenerated via certbot.
i know that there are similar topics but i did not understand from them how to solve my problem, also this is my first time to try to make my site serving over SSL.

1 Like

Hi @esttion

did you run it without --dry-run?

That option

creates only a test certificate and doesn’t install something.

Use the command without --dry-run.

PS: There is a new check of your domain - https://check-your-website.server-daten.de/?q=codeleaf.net#connections

A certificate created yesterday, Grade C. So there is no problem visible.

So you shouldn’t create a new certificate.

PS:

Sounds like a problem of your API. But there is no problem visible. Perhaps share a screenshot.

1 Like

First of all thank you for your fast response.

And thank you for validating that i setup everything correctly on SSL side.

I checked up whole front end code and because i was using VUE.JS my base path url for every API request was 'https://mysite.net/ .

Problem was that i needed to rename it to 'https://WWW.mysite.net/

I am not sure why i had to do that but now it is working OK.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.