Certificate updated successfully, but still get NET::ERR_CERT_COMMON_NAME_INVALID


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: freezoneauditors.org

I ran this command: certbot certonly --webroot-path /etc/letsencrypt --cert-name freezoneauditors.org -d freezoneauditors.org -d www.freezoneauditors.org

It produced this output:

IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:

My web server is (include version): Nginx

The operating system my web server runs on is (include version): Docker

My hosting provider, if applicable, is: Digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Has Nginx been reloaded since the certificate was updated?

Is it configured to use the right certificate and private key files?


#3

Hi. I use Docker and Docker Compose. I’ve restarted a couple of times to no avail. I mount the /etc/letsencrypt folder as a volume in DC. The ssl_certificate in NGINX points to /etc/letsencrypt/live/freezoneauditors.org/…

I rebuilt DC using the --force-recreate too. Thanks so much for your help!


#4

Ah, found out why. There is a symlink pointing to the wrong location!!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.