Namecheap.com webhost can't get ssl for www.domain.tld, only for domain.tld (www is CNAME)

My domain is: apisnectar.com

I ran this command: https://www.sslforfree.com/create?verify_dns&domains=www.apisnectar.com%20apisnectar.com

It produced this output: Domain “www.apisnectar.com” challenge3 failed. Response from “https://acme-v01.api.letsencrypt.org/acme/challenge/XXXXXXXXXX” was: { “type”: “dns-01”, “status”: “invalid”, “error”: { “type”: “urn:acme:error:unauthorized”, “detail”: “Correct value not found for DNS challenge”, “status”: 403 }, “uri”: “https://acme-v01.api.letsencrypt.org/acme/challenge/XXXXXXXXXX”, “token”: “XXXXXXXXX”, “keyAuthorization”: “XXXXXXXXX” }

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: namecheap.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel 62.0.35

I already created the SSL certificate for apisnectar.com but I can’t get it for the same domain with www!

I tried with “Manual Verification” and with “Manuel Verification (DNS)” and both got the message above.

Anyone with the same issue???

My guess is that it’s NameCheap’s DNS taking a minute to get the nameservers updated. Before telling sslforfree to continue, make sure you can query for the challenge records yourself. NameCheap takes up to 10 minutes, in my experience.

Yes, I can. I did it yesterday. That’s not the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.