Challenge failed for domain

Hello ,

first of all I have transferred to namecheap then i hosted it on Google Cloud Console its installed on OpenLiteSpeed server-WordPress and I followed this tutorial to add SSL to my site but the error occurred and I have an A record in Google console with sown-sa.com I can not figure out the issue.

My domain is:sown-sa.com

I ran this command: wget https://dl.eff.org/certbot-auto

It produced this output:
Challenge failed for domain sown-sa.com
http-01 challenge for sown-sa.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: sown-sa.com
    Type: unauthorized
    Detail: Invalid response from
    http://sown-sa.com/.well-known/acme-challenge/xmv3DIvW6eQDut-R6Er-xxTbAFm1PO5n_64F19hfilE
    [35.185.106.11]: "\n<html dir=“rtl”
    lang=“ar”>\n\n<meta charset=“UTF-8”>\n<meta
    name=“viewport” content=“width=device-width, init”

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

My hosting provider, if applicable, is:I am hosting my site on Google Console the free layer

I can login to a root shell on my machine (yes or no, or I don’t know): yes

1 Like

Hi @hanouf

checking that tutorial there is --webroot used. If you have that

not working answer, your webroot may be wrong.

What’s the webroot you have used?

Create the two subdirectories

yourwebroot/.well-known/acme-challenge

there a file (file name 1234), then try to load that file via

http://sown-sa.com/.well-known/acme-challenge/1234

in your browser. If that doesn’t work, you have selected the wrong webroot.

1 Like

I did reset the server and reinstalled it with the certificate.

Thanks

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.