Jobs.thesouthafrican.com

My domain is: jobs.thesouthafrican.com

I ran this command: letsencrypt certonly --webroot -w /home/thesouthafrican_live/code/wordpress -d jobs.thesouthafrican.com --email devops@careerleaf.com --agree-tos --text -vvvvvv

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
Storing nonce: 0001w5fPsZEMGK5BrKxvFHM231LZg0erprEJK_Xq6O4D5zc
Challenge failed for domain jobs.thesouthafrican.com
http-01 challenge for jobs.thesouthafrican.com
Reporting to user: The following errors were reported by the server:

Domain: jobs.thesouthafrican.com
Type: unauthorized
Detail: Invalid response from http://jobs.thesouthafrican.com/.well-known/acme-challenge/OBzb8-g7zZit0jHLHYxT7uLNNdEoOMxONJ52k-CHCos [52.30.1.62]: 404

To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address.

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.38.0

Out put for https://check-your-website.server-daten.de/?q=jobs.thesouthafrican.com looks ok

Your ports 80 and 443 appear to be open and you have a valid A record in your DNS, so those look OK.

The part I’m confused about is that when I visit http://jobs.thesouthafrican.com, I receive the following message:

domain is not defined: jobs.thesouthafrican.com

It looks like the hosting server at https://52.30.1.62 (the IP address of your DNS A record) does not believe that jobs.thesouthafrican.com is hosted there. Thus, the default certificate for careerleaf.com (actually hosted at 52.30.1.62) is being served when trying to visit https://jobs.thesouthafrican.com. Did you clear/destroy/reset your hosting instance? Perhaps you mistyped your IP address in your DNS A record and thus it is pointing to the wrong server?

Thank you for quick response. I think there is some redirection in place. Will check with client.

Thanks again.

1 Like