My SSL not work

My domain is: www.omeralrekany.com

I have added SSL certificate from cloudflare.com on my blogger it worked 30 minutes, after that stopped now the SSL doesn’t work why what the problem can you help me please ?

Thanks

Hi,

It seems that the certificate is working, but the code/setup is having some trouble…

Can you try to turn off “Always Use HTTPS”, " Automatic HTTPS Rewrites" on your Cloudflare dashboard and purge your cache (on your local browser and Cloudflare dashboard)?

Thank you

2 Likes

Welcome to the community btw!

Doesn’t work on http either, it’s a code/config issue.

This page isn’t working www.omeralrekany.com redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS

http://www.redirect-checker.org/index.php confirmed this. Please turn off all redirects via cloudflare and .htaccess (if using apache). If using wordpress, disable any plugins that force https.

2 Likes

Ok I turned off “Always Use HTTPS”, " Automatic HTTPS Rewrites" on Cloudflare
and I selected “NO” in HTTPS sittings in my blogger too cause the domain won’t work if I select “YES”
but I think the blogger doesn’t allow SSL certificate of Cloudflare what do you think?

I did what you said but I selected No in sittings of HTTPS availability therefor the domain will work

Hi @omer,

It appears that HTTPS is working on your domain now.

$ echo | openssl s_client -connect www.omeralrekany.com:443 -servername www.omeralrekany.com 2>&1 | openssl x509 -noout -ext subjectAltName -issuer
X509v3 Subject Alternative Name: 
    DNS:*.omeralrekany.com, DNS:omeralrekany.com, DNS:sni.cloudflaressl.com
issuer=C = US, ST = CA, L = San Francisco, O = "CloudFlare, Inc.", CN = CloudFlare Inc ECC CA-2
$ curl -IL www.omeralrekany.com
HTTP/1.1 301 Moved Permanently
Date: Tue, 04 Jun 2019 15:02:25 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Tue, 04 Jun 2019 16:02:25 GMT
Location: https://www.omeralrekany.com/
Server: cloudflare
CF-RAY: 4e1ac9ab3e699db9-ORD

HTTP/2 200 
date: Tue, 04 Jun 2019 15:02:25 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=dacdc544e80a6cb94cbbf9a3141ea29831559660545; expires=Wed, 03-Jun-20 15:02:25 GMT; path=/; domain=.omeralrekany.com; HttpOnly; Secure
expires: Tue, 04 Jun 2019 15:02:25 GMT
cache-control: private, max-age=0
last-modified: Tue, 04 Jun 2019 13:17:29 GMT
x-content-type-options: nosniff
x-xss-protection: 1; mode=block
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 4e1ac9abd90d5623-ORD
1 Like

When I enter my blogger, press on settings, basic, click on “YES” for
HTTPS availability then the HTTPS redirect button doesn’t work then open my site it appears message "This page isn’t working www.omeralrekany.com redirected you too many times. Try clearing your cookies. ERR_TOO_MANY_REDIRECTS
and I try clear my cookies still the same problem
When click on “YES” for HTTPS availability in my blogger, my site work but without the green padlock in link of https it appears “Your connection to this site is not fully secure” when you press on i character
See the screenshot below



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.