My domain has certificate but it doesnt work


#1

Hello
My domain was already on another server. My previous server had a control panel.
In the control panel, I was able to get a certificate for my domain.my certificate was self signed certificate.
Now I’m transferred to my current server.
How can I get a certificate for my domain on a new server?
I have tried it with certbot. But my certificate still does not work on my domain
Thank you for your guide


#2

Please show the affected domain name.


#3

my domain name is: hyper-design.ir


#4

Two certificates were issued for this domain yesterday, but as of now I’m unable to connect at all. Can you elaborate on exactly how this “doesn’t work” from your point of view? As far as I can tell, the webserver itself is down.


#5

when i was on old server,i get certificate for my domain(a few weeks a go).I did not know that I needed to transfer the certificate.therefor I’m getting a new certificate with certbot(yesterday).certificate for my domain correctly installed but when i enter https://hyper-design.ir in browser,it doesnt work and the word “https” has gray color.


#6

What error does your browser show in this case? It seems like this web server isn’t listening on port 443 at all (at least when testing from the United States), while it is listening on port 80 for HTTP.


#7

error:
This site can’t be reached
hyper-design.ir refused to connect.
Try:
Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

I checked my firewall,the firewall allow 443 port.
Should I make changes to the virtualhost?


#8

port 443 was closed on my server.
I open the port
now , the error change:
when i enter “https://hyper-design.ir” in my browser, i get this error:
This site can’t provide a secure connection
hyper-design.ir sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR


#9

At the moment, the server is running HTTP on port 443.

http://hyper-design.ir:443/ “works”.

If port forwarding is in use, it may be forwarding to the wrong port. Or the Apache configuration is incorrect.


#10

Yes,
Thank you
What should I do to solve this problem?


#11

I did the same thing,

are you able to access your site using https at all ?


#12

No.
When i enter https://hyper-design.ir in my browser, i get this error:
This site can’t provide a secure connection
hyper-design.ir sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR


#13

yeah, then you sometimes get the ssl handshake errors?

I made the mistake to create multiple certificates now when I try to connect to https:// it refuses the connection.

still trying to find a fix.


#14

This error(ssl handshake) has not happened to me until now


#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.