My apache web server shows welcome page instead of my web

My domain is:

I ran this command: I configured HTTPS with certbot

After I setup my certbot for my web ssl certification my website opens apache welcome page.

I run the following code and I get this resualt.

sudo apachectl -t -D DUMP_VHOSTS

*:80 (/etc/httpd/conf/httpd.conf:43)
*:443 is a NameVirtualHost
default server (/etc/httpd/conf.d/ssl.conf:56)
port 443 namevhost (/etc/httpd/conf.d/ssl.conf:56)
port 443 namevhost (/etc/httpd/conf/httpd-le-ssl.conf:2)

What page were you expecting instead?

Can you show the contents of these two config files? Please put 3 backticks before and after each one like this so no settings are lost

contents of: /etc/httpd/conf/httpd.conf

contents of: /etc/httpd/conf/httpd-le-ssl.conf


Hi @karentumba, and welcome to the LE community forum :slight_smile:

It seems like the HTTPS vhost is a copy of the HTTP vhost.
Both of which only serve the "www" name.
Were you expecting otherwise?
Are you trying to reach
If so, then should have been configured first.
Note: That might have worked simply because there is no other HTTP vhost - so, it gets served for all HTTP requests. Which is NOT the case for HTTPS.
To that synchronization end...
What exactly are you using this vhost for?:

If it is NOT required, then you could just delete that file and end up with the same default situation you have with HTTP on the HTTPS side.
Which will "work" until you decide to add another site to your web server configuration ...
[food for thought - you can do it right (fix it) or do it again (fix it) each time you make a change]

My advice is to add the base name to both vhosts.
And ensure the cert used has both names on it.

As I suspected, the cert in use only has one name on it:
SSL Server Test: (Powered by Qualys SSL Labs)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.